Emacs 21.2 and MySQL 3.23.49 available

bridged with qdn.public.qnxrtp.applications
Post Reply
Andrew Thomas

Emacs 21.2 and MySQL 3.23.49 available

Post by Andrew Thomas » Wed Jun 12, 2002 5:15 pm

Emacs 21.2 and MySQL 3.23.49 are now available for
QNX 6.2 release version (NC will do). Point the
"old" package installer, pkg-installer, at the
repository at
http://developers.cogentrts.com/repository
and install from there.

Notes:
======
1) There is no source available for MySQL, and the
source archive for emacs doesn't compile. In
both cases we had to hack the C libraries and
headers to get them to compile and run.
2) Emacs requires that you install the X-Windows
libraries, even if you plan to run in a
terminal with "emacs -nw". The best choice is
to install XFree86 from the 3rd-party CD, and
create the link:
ln -s ../opt/X11R6 /usr
then run XPhoton to get a session within Photon.
If you don't want to download the entire 3rd-
party CD just for XFree86, point the package
installer at:
http://qnx.wox.org/qnxpub100

Cheers,
Andrew

Martin Tilsted

Re: Emacs 21.2 and MySQL 3.23.49 available

Post by Martin Tilsted » Fri Jun 14, 2002 3:53 am

Andrew Thomas wrote:
Emacs 21.2 and MySQL 3.23.49 are now available for
QNX 6.2 release version (NC will do). Point the
"old" package installer, pkg-installer, at the
repository at
http://developers.cogentrts.com/repository
and install from there.
I am running emacs now. Works great but I have one question.
I am using a few scripts(*.el) where do I need to put them in order to
ensure that emacs load them on startup?

The only solution I found was to cat them all togethor in one file, and
then doing a emacs --load startup.el MyFile.cc but this is a bit
anoying. How do I set emacs to load them on startup?

Martin Tilsted

David Gibbs

Re: Emacs 21.2 and MySQL 3.23.49 available

Post by David Gibbs » Fri Jun 14, 2002 2:59 pm

Martin Tilsted <tiller@daimi.au.dk> wrote:
Andrew Thomas wrote:
Emacs 21.2 and MySQL 3.23.49 are now available for
QNX 6.2 release version (NC will do). Point the
"old" package installer, pkg-installer, at the
repository at
http://developers.cogentrts.com/repository
and install from there.

I am running emacs now. Works great but I have one question.
I am using a few scripts(*.el) where do I need to put them in order to
ensure that emacs load them on startup?

The only solution I found was to cat them all togethor in one file, and
then doing a emacs --load startup.el MyFile.cc but this is a bit
anoying. How do I set emacs to load them on startup?
If somebody doesn't give you an emacs solution, there is always

alias emacs="emacs --load startup.el"

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

Jens H Jorgensen

Re: Emacs 21.2 and MySQL 3.23.49 available

Post by Jens H Jorgensen » Fri Jun 14, 2002 3:36 pm

I am pretty sure this would work (please note I am not an emacs lisp
expert):

1. Create a .emacs in your root.
2. Add following lines to the .emacs:

(load "file1")
(load "file2")

where file1.el and file2.el are the files you want to load.

I do the above with cc-mode in my .emacs. I can't remember if your .el files
needs to be compiled into .elc before above will work. If you need to
compile the .el files then try following:

emacs -q -no-site-file --batch -f batch-byte-compile *.el
--
Jens

"Martin Tilsted" <tiller@daimi.au.dk> wrote in message
news:3D0968B2.9090207@daimi.au.dk...
Andrew Thomas wrote:
Emacs 21.2 and MySQL 3.23.49 are now available for
QNX 6.2 release version (NC will do). Point the
"old" package installer, pkg-installer, at the
repository at
http://developers.cogentrts.com/repository
and install from there.

I am running emacs now. Works great but I have one question.
I am using a few scripts(*.el) where do I need to put them in order to
ensure that emacs load them on startup?

The only solution I found was to cat them all togethor in one file, and
then doing a emacs --load startup.el MyFile.cc but this is a bit
anoying. How do I set emacs to load them on startup?

Martin Tilsted

Jens H Jorgensen

Re: Emacs 21.2 and MySQL 3.23.49 available

Post by Jens H Jorgensen » Fri Jun 14, 2002 3:37 pm

Sorry that is:
1. Create a .emacs in your home directory
^^^^^^^^^^^^^^^^^^^
--
Jens

"Jens H Jorgensen" <jhj@remove-nospam-videk.com> wrote in message
news:aed1od$blb$1@inn.qnx.com...
I am pretty sure this would work (please note I am not an emacs lisp
expert):

1. Create a .emacs in your root.
2. Add following lines to the .emacs:

(load "file1")
(load "file2")

where file1.el and file2.el are the files you want to load.

I do the above with cc-mode in my .emacs. I can't remember if your .el
files
needs to be compiled into .elc before above will work. If you need to
compile the .el files then try following:

emacs -q -no-site-file --batch -f batch-byte-compile *.el
--
Jens

"Martin Tilsted" <tiller@daimi.au.dk> wrote in message
news:3D0968B2.9090207@daimi.au.dk...
Andrew Thomas wrote:
Emacs 21.2 and MySQL 3.23.49 are now available for
QNX 6.2 release version (NC will do). Point the
"old" package installer, pkg-installer, at the
repository at
http://developers.cogentrts.com/repository
and install from there.

I am running emacs now. Works great but I have one question.
I am using a few scripts(*.el) where do I need to put them in order to
ensure that emacs load them on startup?

The only solution I found was to cat them all togethor in one file, and
then doing a emacs --load startup.el MyFile.cc but this is a bit
anoying. How do I set emacs to load them on startup?

Martin Tilsted


Post Reply

Return to “qdn.public.qnxrtp.applications”