Installer:How to satisfy unsatisfied packages???

bridged with qdn.public.qnxrtp.applications
Post Reply
Otto Mixa

Installer:How to satisfy unsatisfied packages???

Post by Otto Mixa » Tue Jan 07, 2003 4:45 pm

Hello,
I have got installed some packages and theirs status is unsatisfied,
Does anybody know how to satisfy they? I know that this is probably that
I'm missing some kind of library, but how to find it which one and where
I can download it...
Thanks a lot for all comments.
Otto

Alain Bonnefoy

Re: Installer:How to satisfy unsatisfied packages???

Post by Alain Bonnefoy » Wed Jan 08, 2003 7:25 am

After having tried to install your package, it should appear in red. If
you click on, it should display in the description onglet (click on the
button on the right of the target's list box if you don't see it)
which dependency problem it encountered.
Otherwise, before installing it, you can choose the Content onglet of
the x86 package. Then look at the requirements list, you will everything
your package needs to be corretly installed.

Regards,
Alain.

Otto Mixa a écrit:
Hello,
I have got installed some packages and theirs status is unsatisfied,
Does anybody know how to satisfy they? I know that this is probably
that I'm missing some kind of library, but how to find it which one
and where I can download it...
Thanks a lot for all comments.
Otto

Otto Mixa

Re: Installer:How to satisfy unsatisfied packages???

Post by Otto Mixa » Wed Jan 08, 2003 10:16 am

Yes I know about the Content,and about the libraries which is in my system
missing,
but my question is : If I will in future install the required
libraries...will the unsatisfied packages come to satisfy status? And
another thing is that I have got installed all avalaible libraries from QNX
web repositories and also from 3rd party repositories....So where I can find
required libraries? It seems that doesn't exist :-(
I'm confused why is some packages distributed without required libraries
(because libraries still became to new versions), and if I will have got the
newest libraries version then I can't satisfy this packages because its hard
to find older libraries in any repositories.
The mentioned unsatisfied packages are for example DDD,Opera and other 3rd
party packages.
(I'm just now in other OS,so I can't check it,but I know that I have got
about 7 unsatisfied packages)
Well, is that mean that all of you give me advice dont't install packages
where in Content is some required libraries which I haven't got?
Thanks a lot for all comments and BTW how many unsatisfied packages have got
you guys?

Otto

"Alain Bonnefoy" <alain.bonnefoy@icbt.com> wrote in message
news:3E1BD258.4060506@icbt.com...
After having tried to install your package, it should appear in red. If
you click on, it should display in the description onglet (click on the
button on the right of the target's list box if you don't see it)
which dependency problem it encountered.
Otherwise, before installing it, you can choose the Content onglet of
the x86 package. Then look at the requirements list, you will everything
your package needs to be corretly installed.

Regards,
Alain.

Otto Mixa a écrit:

Hello,
I have got installed some packages and theirs status is unsatisfied,
Does anybody know how to satisfy they? I know that this is probably
that I'm missing some kind of library, but how to find it which one
and where I can download it...
Thanks a lot for all comments.
Otto

Guest

Re: Installer:How to satisfy unsatisfied packages???

Post by Guest » Sat Jan 11, 2003 7:10 pm

ottomixa@email.cz sed in <avgsm4$pec$1@inn.qnx.com>:
but my question is : If I will in future install the required
libraries...will the unsatisfied packages come to satisfy status? And
Should be. (not tested)
another thing is that I have got installed all avalaible libraries from QNX
web repositories and also from 3rd party repositories....So where I can find
required libraries? It seems that doesn't exist :-(
"Good" packages have repository URLs embedded for auto retrieval,
but if not, you have to find it yourself.
If you can't find it, out of luck.
newest libraries version then I can't satisfy this packages because its hard
to find older libraries in any repositories.
The mentioned unsatisfied packages are for example DDD,Opera and other 3rd
party packages.
I haven't have any problems like this, but
Are you stuffing 6.0 packages into 6.2?
(I expect only post-6.1 packages work on 6.2...)

From your other posts, you seem to have rather "dirty" installation;
does clean install using a fresh partition fix problems?
Don't try to cram in all the 3rd party things at once;
you won't know where it went wrong. Do it one by one.
--
kabe

Post Reply

Return to “qdn.public.qnxrtp.applications”