Running

bridged with qdn.public.qnxrtp.applications
Post Reply
Dorothea Mücke-Herzberg

Running

Post by Dorothea Mücke-Herzberg » Thu Sep 25, 2003 1:26 pm

Hello,

We would like to run X11 applications like emacs via
Phindows. Our problem is that emacs gets launched
on the attached screen of the QNX node, not in the Phindows
session. The DISPLAY variable is currently: 127.1:0.
So this is actually not a surprise. The question is,
what DISPLAY variable do we have to set for the Phindows
session? How can we find out?

(We have installed QNX6.2.1a, the XFree binaries and
libraries and XPhoton)

Thank you all

Dorothea

Garry Turcotte

Re: Running

Post by Garry Turcotte » Thu Sep 25, 2003 2:15 pm

In the phindows session run
$ XPhoton :1 &
$ export DISPLAY=127.1:1.0
$ x_app

Dorothea Mücke-Herzberg wrote:
Hello,

We would like to run X11 applications like emacs via
Phindows. Our problem is that emacs gets launched
on the attached screen of the QNX node, not in the Phindows
session. The DISPLAY variable is currently: 127.1:0.
So this is actually not a surprise. The question is,
what DISPLAY variable do we have to set for the Phindows
session? How can we find out?

(We have installed QNX6.2.1a, the XFree binaries and
libraries and XPhoton)

Thank you all

Dorothea

Dorothea Mücke-Herzberg

Re: Running

Post by Dorothea Mücke-Herzberg » Fri Sep 26, 2003 10:49 am

Hi Garry,

Thank you. That worked - sort of.
I can open an x-application now, but
everything inside the x-application is black.
Any ideas?

Thank you

Dorothea

-----Original Message-----
From: Garry Turcotte [mailto:garry@qnx.com]
Posted At: 25 September 2003 15:16
Posted To: applications
Conversation: Running
Subject: Re: Running


In the phindows session run
$ XPhoton :1 &
$ export DISPLAY=127.1:1.0
$ x_app

Dorothea Mücke-Herzberg wrote:
Hello,

We would like to run X11 applications like emacs via
Phindows. Our problem is that emacs gets launched
on the attached screen of the QNX node, not in the Phindows
session. The DISPLAY variable is currently: 127.1:0.
So this is actually not a surprise. The question is,
what DISPLAY variable do we have to set for the Phindows
session? How can we find out?

(We have installed QNX6.2.1a, the XFree binaries and
libraries and XPhoton)

Thank you all

Dorothea

Garry Turcotte

Re: Running

Post by Garry Turcotte » Fri Sep 26, 2003 1:04 pm

All the X rendering gets sent to phindows as images.
My guess is that the phindows memory cache is too small
or you're running an old XPhoton that doesn't send
CRC's with the images (or a new one with -nocrc)
In either case, the image data won't be transmitted
and a black rect gets drawn...

Dorothea Mücke-Herzberg wrote:
Hi Garry,

Thank you. That worked - sort of.
I can open an x-application now, but
everything inside the x-application is black.
Any ideas?

Thank you

Dorothea



-----Original Message-----
From: Garry Turcotte [mailto:garry@qnx.com]
Posted At: 25 September 2003 15:16
Posted To: applications
Conversation: Running
Subject: Re: Running


In the phindows session run
$ XPhoton :1 &
$ export DISPLAY=127.1:1.0
$ x_app

Dorothea Mücke-Herzberg wrote:

Hello,

We would like to run X11 applications like emacs via
Phindows. Our problem is that emacs gets launched
on the attached screen of the QNX node, not in the Phindows
session. The DISPLAY variable is currently: 127.1:0.
So this is actually not a surprise. The question is,
what DISPLAY variable do we have to set for the Phindows
session? How can we find out?

(We have installed QNX6.2.1a, the XFree binaries and
libraries and XPhoton)

Thank you all

Dorothea



Post Reply

Return to “qdn.public.qnxrtp.applications”