lpd is too damn quiet

bridged with qdn.public.qnxrtp.applications
Post Reply
Bill Caroselli

lpd is too damn quiet

Post by Bill Caroselli » Tue Dec 02, 2003 3:01 pm

I was making changes to my /etc/printcap file. lpd died.

OK. Understandable. I made a mistake. I found it and fixed it.
I reloaded lpd and it immedaitely died, silently.

I put my /etc/printcap file back to the way it originally was.
I reloaded lpd and it died again without a clue as to why.

After an hour of screwing around with this I finally went into each
printers spool directory and deleted everything that was there.

I reloaded lpd and it worked just fine.

It lpd had displayed *WHY* it was terminating it would have saved me
a lot of time. At least add a -v option to be more verbose every time
lpd decides not to do what you ask it to do.

If this makes lpd non-cobnforming to posix, THEN SO BE IT!

Steve Reid

Re: lpd is too damn quiet

Post by Steve Reid » Tue Dec 02, 2003 4:44 pm

Bill Caroselli <qtps@earthlink.net> wrote:
It lpd had displayed *WHY* it was terminating it would have saved me
a lot of time. At least add a -v option to be more verbose every time
lpd decides not to do what you ask it to do.

If this makes lpd non-cobnforming to posix, THEN SO BE IT!
Are you running syslogd? I'm told that lpd, which (as you've seen) is
normally very quiet, is quite verbose in the log, which will likely help
you find the problem. The docs for lpd mention syslogd, but they should
emphasize how useful the log is if problems occur.

I hope this helps.

------------------------------------------
Steve Reid stever@qnx.com
TechPubs (Technical Publications)
QNX Software Systems
------------------------------------------

Bill Caroselli

Re: lpd is too damn quiet

Post by Bill Caroselli » Tue Dec 02, 2003 8:45 pm

Roger Smith <hamtaro@hotmail.com> wrote:
RS > lpd is presumably a port of some open source (GNU?) lpd with little if
RS > any QNX-ification, so it's going to use syslog like your typical UNIX
RS > service.

RS > QNX can sometimes be confusing. Some stuff works like the standard UNIX
RS > stuff, and some is purely QNX.

The fact is, when the problem occured I loaded syslogd to see what if
anything it would show. It showed nothing. I realized that the log
file had not been created to I touched it. It still logged nothing.

I had to slay syslogd *after I touched the log file* before syslogd was
willing to do its job.

So, SYSLOGD IS ALSO TOO DAMN QUIET!

Roger Smith

Re: lpd is too damn quiet

Post by Roger Smith » Tue Dec 02, 2003 8:59 pm

lpd is presumably a port of some open source (GNU?) lpd with little if
any QNX-ification, so it's going to use syslog like your typical UNIX
service.

QNX can sometimes be confusing. Some stuff works like the standard UNIX
stuff, and some is purely QNX.

David Gibbs

Re: lpd is too damn quiet

Post by David Gibbs » Tue Dec 02, 2003 9:20 pm

Roger Smith <hamtaro@hotmail.com> wrote:
lpd is presumably a port of some open source (GNU?)
BSD, I think.

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

Alain Bonnefoy

Re: lpd is too damn quiet

Post by Alain Bonnefoy » Wed Dec 03, 2003 6:37 am

Hum,
We could reasonably guess that it's due to a bug :-P !
In that case lpd itself doesn't know why and how it dies so, how can it
say anything?
Alain.

Bill Caroselli a écrit:
I was making changes to my /etc/printcap file. lpd died.

OK. Understandable. I made a mistake. I found it and fixed it.
I reloaded lpd and it immedaitely died, silently.

I put my /etc/printcap file back to the way it originally was.
I reloaded lpd and it died again without a clue as to why.

After an hour of screwing around with this I finally went into each
printers spool directory and deleted everything that was there.

I reloaded lpd and it worked just fine.

It lpd had displayed *WHY* it was terminating it would have saved me
a lot of time. At least add a -v option to be more verbose every time
lpd decides not to do what you ask it to do.

If this makes lpd non-cobnforming to posix, THEN SO BE IT!

John Nagle

Re: lpd is too damn quiet

Post by John Nagle » Sun Dec 07, 2003 7:16 pm

Printing under QNX is documented very badly. The
unfinished "system administration guide" isn't too helpful.
The manual focuses on printers not seen since the 1980s.

You have to be really l33t just to get a printer to work.

Photon printing eventually goes through lpd, but the chain of events
is complicated and hard to diagnose.

The spooling system uses lock files, which are archaic and
tend to result in stuck daemons.

John Nagle

Bill Caroselli wrote:
I was making changes to my /etc/printcap file. lpd died.

OK. Understandable. I made a mistake. I found it and fixed it.
I reloaded lpd and it immedaitely died, silently.

I put my /etc/printcap file back to the way it originally was.
I reloaded lpd and it died again without a clue as to why.

After an hour of screwing around with this I finally went into each
printers spool directory and deleted everything that was there.

I reloaded lpd and it worked just fine.

It lpd had displayed *WHY* it was terminating it would have saved me
a lot of time. At least add a -v option to be more verbose every time
lpd decides not to do what you ask it to do.

If this makes lpd non-cobnforming to posix, THEN SO BE IT!

John A. Murphy

Re: lpd is too damn quiet

Post by John A. Murphy » Mon Dec 08, 2003 2:43 am

I'd certainly agree that printing under QNX is "a challenge." After
many hours of trying to decipher the documentation, I finally just wrote
a tiny utility that sends files I want to print directly to a networked
printer. Certainly not the right way to get the job done, but at least I
can print now.

Murf

John Nagle wrote:
Printing under QNX is documented very badly. The
unfinished "system administration guide" isn't too helpful.
The manual focuses on printers not seen since the 1980s.

You have to be really l33t just to get a printer to work.

Photon printing eventually goes through lpd, but the chain of events
is complicated and hard to diagnose.

The spooling system uses lock files, which are archaic and
tend to result in stuck daemons.

John Nagle

Bill Caroselli wrote:
I was making changes to my /etc/printcap file. lpd died.

OK. Understandable. I made a mistake. I found it and fixed it.
I reloaded lpd and it immedaitely died, silently.

I put my /etc/printcap file back to the way it originally was.
I reloaded lpd and it died again without a clue as to why.

After an hour of screwing around with this I finally went into each
printers spool directory and deleted everything that was there.

I reloaded lpd and it worked just fine.

It lpd had displayed *WHY* it was terminating it would have saved me
a lot of time. At least add a -v option to be more verbose every time
lpd decides not to do what you ask it to do.

If this makes lpd non-cobnforming to posix, THEN SO BE IT!

Post Reply

Return to “qdn.public.qnxrtp.applications”