addvariant macro is not working

bridged with qdn.public.qnxrtp.mips
Post Reply
Lung Han

addvariant macro is not working

Post by Lung Han » Fri Aug 09, 2002 10:20 pm

Hi,

The addvariant macro is not quite working right. The -i option is fine. But
the non -i option is not. Has anybody ever have the same problems?

Thanks.

Chris McKillop

Re: addvariant macro is not working

Post by Chris McKillop » Fri Aug 09, 2002 11:00 pm

Could you post the exact command lines you are using? Are you doing this
from Windows or Solaris?

chris

Lung Han <lhan@eitc.epson.com> wrote:
Hi,

The addvariant macro is not quite working right. The -i option is fine. But
the non -i option is not. Has anybody ever have the same problems?

Thanks.

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Lung Han

Re: addvariant macro is not working

Post by Lung Han » Mon Aug 12, 2002 5:22 pm

Hi Chris,

The lines I was used as follows:

mkdir test
cd ./test
addvariant -i OS // common.mk and Makefile are created, so far so
good
addvariant nto // nothing happened

I then try
mkdir nto
addvariant nto // still nothing happened

I am running Windows. I think running qnxnc620.iso may be the reason.

Thanks.

"Chris McKillop" <cdm@qnx.com> wrote in message
news:aj1hj5$n8i$1@nntp.qnx.com...
Could you post the exact command lines you are using? Are you doing this
from Windows or Solaris?

chris

Lung Han <lhan@eitc.epson.com> wrote:
Hi,

The addvariant macro is not quite working right. The -i option is fine.
But
the non -i option is not. Has anybody ever have the same problems?

Thanks.



--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Chris McKillop

Re: addvariant macro is not working

Post by Chris McKillop » Mon Aug 12, 2002 9:39 pm

Lung Han <lhan@eitc.epson.com> wrote:
Hi Chris,

The lines I was used as follows:

mkdir test
cd ./test
addvariant -i OS // common.mk and Makefile are created, so far so
good
addvariant nto // nothing happened

I then try
mkdir nto
addvariant nto // still nothing happened

I am running Windows. I think running qnxnc620.iso may be the reason.
Your first line should include the first variant you want to use...ie:

addvariant -i OS nto ppc o.be

After that you can simply do the addvariant lines...

addvariant nto x86 o
addvariant nto arm o.le
....

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Post Reply

Return to “qdn.public.qnxrtp.mips”