problem with PCI-interrupt

bridged with qdn.public.qnxrtp.x86
Post Reply
Daniel

problem with PCI-interrupt

Post by Daniel » Mon Aug 18, 2003 8:48 am

Hi,

I have a problem with a PCI-I/O card. There are some interrupt-testing
applications from the manufacturer. They don't work on my System. The
interrupt is triggerd on the PCI-board, but InterruptWait(), after
successful InterruptAttachEvent() doesn't work. The manufacturer used QNX
6.1.x to test the interrupt and it worked. I use QNX 6.2.1 and the same
resource manager and same application and it doesn't. I use it on Pentium 4
1800 MHz. I also tested with Pentium 4 2400 MHz. The Interrupt works under
Windows XP. Don't know what system the manufacturer uses.
Any ideas?

Thanks
Daniel

Ricardo Peres

Re: problem with PCI-interrupt

Post by Ricardo Peres » Tue Sep 02, 2003 12:25 pm

Hi there,

I have tried to use the InterruptWait() with a serial board on ISA bus and I
had the same problem!

In my case, We had to use other approach (we have changed to use the
devc-ser8250).

Good luck.

Regards

Ricardo Peres


--
T-Systems do Brasil Ltda.
TMAN - Eng. de Automação Industrial
Al. Campinas, 1070 - 11º andar
01404-002 - São Paulo - SP - Brazil
Phone: (55) (11) 3886-8287 or 3886-8297
Fax: (55) (11) 3886-2824

"Daniel" <daniel-grimm@gmx.de> wrote in message
news:bhq373$c0p$1@inn.qnx.com...
Hi,

I have a problem with a PCI-I/O card. There are some interrupt-testing
applications from the manufacturer. They don't work on my System. The
interrupt is triggerd on the PCI-board, but InterruptWait(), after
successful InterruptAttachEvent() doesn't work. The manufacturer used QNX
6.1.x to test the interrupt and it worked. I use QNX 6.2.1 and the same
resource manager and same application and it doesn't. I use it on Pentium
4
1800 MHz. I also tested with Pentium 4 2400 MHz. The Interrupt works under
Windows XP. Don't know what system the manufacturer uses.
Any ideas?

Thanks
Daniel

Post Reply

Return to “qdn.public.qnxrtp.x86”