How to enter á and í at the QNX cmdline??

bridged with qdn.public.qnx2
Post Reply
Guest

How to enter á and í at the QNX cmdline??

Post by Guest » Fri Feb 21, 2003 3:16 pm

I am trying to enter á and íon the QNX command line and the cursor keeps going to the top left corner
of the screen when i enter alt, a, ' or alt, i, ' have also tried
alt a 0 and alt a 1 neither way works.


I have changed a few stty settings(+efunc), didn't help. I am using the
101.US keyboard.

Anyone able to type á and í from your QNX command line, if so what keyboard and stty settings are
you using????

Any other suggestions would be appreciated.

Thanks,
Ray

Pascal Simler

Re: How to enter á and í at the QNX cmdline??

Post by Pascal Simler » Thu Feb 27, 2003 10:26 am

Alt (ASCII code in Hexa ) should work

Try Alt 85 and Alt 8d

Pascal
<Ray.PARKS@na.biomerieux.com> wrote in message news:b35frh$hq6$1@inn.qnx.com...

I am trying to enter á and íon the QNX command line and the cursor keeps going to the top left corner
of the screen when i enter alt, a, ' or alt, i, ' have also tried alt a 0 and alt a 1 neither way works.


I have changed a few stty settings(+efunc), didn't help. I am using the 101.US keyboard.

Anyone able to type á and í from your QNX command line, if so what keyboard and stty settings are you using????

Any other suggestions would be appreciated.

Thanks,
Ray

Pascal Simler

Re: How to enter á and í at the QNX cmdline??

Post by Pascal Simler » Thu Feb 27, 2003 11:06 am

Sorry, you need the accents from top rigth to bottom left !
The ascci codes are a0 and a1.
Tried on the command line but does not work, because
a1 = up and a0 = home.
But in ed editor it works !

Pascal
<Ray.PARKS@na.biomerieux.com> wrote in message news:b35frh$hq6$1@inn.qnx.com...

I am trying to enter á and íon the QNX command line and the cursor keeps going to the top left corner
of the screen when i enter alt, a, ' or alt, i, ' have also tried alt a 0 and alt a 1 neither way works.


I have changed a few stty settings(+efunc), didn't help. I am using the 101.US keyboard.

Anyone able to type á and í from your QNX command line, if so what keyboard and stty settings are you using????

Any other suggestions would be appreciated.

Thanks,
Ray

Guest

Re: How to enter á and í at the QNX cmdline??

Post by Guest » Thu Feb 27, 2003 7:22 pm

Pascal,


Thanks for the reply.

Yes we know that á and í can be entered from the within an editor.

Our problem is we are taking input from the QNX command line and need the
characters á and í .
Do you think this is an OS issue?? á and í are part of the Standard Console Character Set....but don't work on the
cmdline.

Thanks,
Ray

Pascal Simler

Re: How to enter á and í at the QNX cmdline??

Post by Pascal Simler » Fri Feb 28, 2003 11:46 am

Well, could these be alternatives :

* Write a command.sh file with ed containing your characters and launch it
from the cmd line with : 'sh command.sh'.

* I wrote a long time ago ( 15 years now ) a librairy with character input
functions and it works with these special characters. Perhaps you could
write an executable linked to this library who returns the input to the
command line !

Pascal


<Ray.PARKS@na.biomerieux.com> wrote in message
news:b3lohu$fr$1@inn.qnx.com...
Pascal,


Thanks for the reply.

Yes we know that á and í can be entered from the within an editor.

Our problem is we are taking input from the QNX command line and need the
characters á and í .
Do you think this is an OS issue?? á and í are part of the Standard
Console Character Set....but don't work on the
cmdline.

Thanks,
Ray

David Gibbs

Re: How to enter á and í at the QNX cmdline??

Post by David Gibbs » Mon Mar 03, 2003 3:12 pm

Ray.PARKS@na.biomerieux.com wrote:
Pascal,
Thanks for the reply.

Yes we know that á and í can be entered from the within an editor.

Our problem is we are taking input from the QNX command line and need the
characters á and í .
Do you think this is an OS issue?? á and í are part of the Standard Console Character Set....but don't work on the
cmdline.
From the sound of it, these overlap with HOME and END in the standard
character set -- you could try using either stty (command line) or the
tcsetattr()/tcgetattr() functions to un-map these characters from
that. Might work.

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

Guest

Re: How to enter á and í at the QNX cmdline??

Post by Guest » Wed Mar 05, 2003 1:27 pm

David, as you suggested below, I tried more stty settings, I also changed
tcap definitions and could not get
the á and í std console characters to display on the command line. We
are using QNX2 Version 3.21. We are starting to
enter several other languages which use these accented letters. Our
current program takes input from the commandline
and stores the inputted data in a database.

We are using a C86 compiler and I did not see the functions tcsetattr()/tcgetattr().


Any other recommendations or suggestions would be appreciated. Thanks,
Ray.

From the sound of it, these overlap with HOME and END in the standard
character set -- you could try using either stty (command line) or the
tcsetattr()/tcgetattr() functions to un-map these characters from
that. Might work.

-David

David Gibbs

Re: How to enter á and í at the QNX cmdline??

Post by David Gibbs » Wed Mar 05, 2003 3:40 pm

Ray.PARKS@na.biomerieux.com wrote:
David, as you suggested below, I tried more stty settings, I also changed
tcap definitions and could not get
the á and í std console characters to display on the command line. We
are using QNX2 Version 3.21. We are starting to
enter several other languages which use these accented letters. Our
current program takes input from the commandline
and stores the inputted data in a database.

We are using a C86 compiler and I did not see the functions
tcsetattr()/tcgetattr().
Any other recommendations or suggestions would be appreciated. Thanks,
Ray.
Oops...forgot it was QNX2... that makes things much more difficult, it
probably doesn't have the tcsetattr()/getattr() functions. Sorry for
suggesting them.

Don't have anything else to suggest either :(

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

Post Reply

Return to “qdn.public.qnx2”