file busy

bridged with qdn.public.qnx2
Post Reply
gerg

file busy

Post by gerg » Mon Nov 24, 2003 3:38 pm

When I try to frel a file I get the message 'file busy'. How do I unbusy or
whatever it takes to delete a file?

David Gibbs

Re: file busy

Post by David Gibbs » Mon Nov 24, 2003 4:08 pm

gerg <gerg@nome.com> wrote:
When I try to frel a file I get the message 'file busy'. How do I unbusy or
whatever it takes to delete a file?
I think you have to use the chattr (change attributes) utility to unset
the busy flag on the file.

Probably something like:

chattr -b filename

(Note: the docs suggest running chkfsys after unbusying a file to make
sure the contents are consistent.)

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

gerg

Re: file busy

Post by gerg » Mon Nov 24, 2003 5:14 pm

I tried the chattr cmd then I tried frel and I get the message unable to
open. Also, I typed files +b and i still get the dame files as being busy.
"David Gibbs" <dagibbs@qnx.com> wrote in message
news:bptadu$ifd$3@nntp.qnx.com...
gerg <gerg@nome.com> wrote:
When I try to frel a file I get the message 'file busy'. How do I
unbusy or
whatever it takes to delete a file?

I think you have to use the chattr (change attributes) utility to unset
the busy flag on the file.

Probably something like:

chattr -b filename

(Note: the docs suggest running chkfsys after unbusying a file to make
sure the contents are consistent.)

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

gerg

Re: file busy

Post by gerg » Mon Nov 24, 2003 5:27 pm

Please accept my appologies the word -dame- should be -same-
"gerg" <gerg@nome.com> wrote in message news:bptd3n$fof$1@inn.qnx.com...
I tried the chattr cmd then I tried frel and I get the message unable to
open. Also, I typed files +b and i still get the dame files as being
busy.
"David Gibbs" <dagibbs@qnx.com> wrote in message
news:bptadu$ifd$3@nntp.qnx.com...
gerg <gerg@nome.com> wrote:
When I try to frel a file I get the message 'file busy'. How do I
unbusy or
whatever it takes to delete a file?

I think you have to use the chattr (change attributes) utility to unset
the busy flag on the file.

Probably something like:

chattr -b filename

(Note: the docs suggest running chkfsys after unbusying a file to make
sure the contents are consistent.)

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

David Gibbs

Re: file busy

Post by David Gibbs » Mon Nov 24, 2003 9:33 pm

gerg <gerg@nome.com> wrote:
Please accept my appologies the word -dame- should be -same-
"gerg" <gerg@nome.com> wrote in message news:bptd3n$fof$1@inn.qnx.com...
I tried the chattr cmd then I tried frel and I get the message unable to
open. Also, I typed files +b and i still get the dame files as being
busy.
Did the chattr fail? Do you have modify permission for the file in
question? If you don't have modify, you can't do the above chattr.

If you don't have modify permission, you can't restore it. (Yup.)

Since you're trying to delete these anyway, it might be time to try
the bigger hammer: zap

zap filename

Then run chkfsys to reclaim the blocks.

-David
"David Gibbs" <dagibbs@qnx.com> wrote in message
news:bptadu$ifd$3@nntp.qnx.com...
gerg <gerg@nome.com> wrote:
When I try to frel a file I get the message 'file busy'. How do I
unbusy or
whatever it takes to delete a file?

I think you have to use the chattr (change attributes) utility to unset
the busy flag on the file.

Probably something like:

chattr -b filename

(Note: the docs suggest running chkfsys after unbusying a file to make
sure the contents are consistent.)

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.


--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

Mike Schneider

Re: file busy

Post by Mike Schneider » Tue Nov 25, 2003 12:21 pm

If the file was not closed properly while writing, for example if the
system was powered down while writing, the file could be corrupted and can
not be unbusied using the chattr command.
For busy files in general, first check that it is not currently being used
by an application by using "fopen". Then try and chattr it to be unbusy.
If that fails then you can zap it to delete it, and as Dave said, if you
need to recover the space lost by zapped files, you must run chkfsys.
Use '?' to get command options, "chattr ?", etc.
ms...

David Gibbs wrote:
gerg <gerg@nome.com> wrote:
Please accept my appologies the word -dame- should be -same-
"gerg" <gerg@nome.com> wrote in message news:bptd3n$fof$1@inn.qnx.com...
I tried the chattr cmd then I tried frel and I get the message unable to
open. Also, I typed files +b and i still get the dame files as being
busy.

Did the chattr fail? Do you have modify permission for the file in
question? If you don't have modify, you can't do the above chattr.

If you don't have modify permission, you can't restore it. (Yup.)

Since you're trying to delete these anyway, it might be time to try
the bigger hammer: zap

zap filename

Then run chkfsys to reclaim the blocks.

-David

"David Gibbs" <dagibbs@qnx.com> wrote in message
news:bptadu$ifd$3@nntp.qnx.com...
gerg <gerg@nome.com> wrote:
When I try to frel a file I get the message 'file busy'. How do I
unbusy or
whatever it takes to delete a file?

I think you have to use the chattr (change attributes) utility to unset
the busy flag on the file.

Probably something like:

chattr -b filename

(Note: the docs suggest running chkfsys after unbusying a file to make
sure the contents are consistent.)

-David
--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

--
QNX Training Services
http://www.qnx.com/support/training/
Please followup in this newsgroup if you have further questions.

Post Reply

Return to “qdn.public.qnx2”