Repost: Which Eclipse version?

bridged with qnx.development_tools
Post Reply
Carl Rosenberger

Repost: Which Eclipse version?

Post by Carl Rosenberger » Fri Jan 09, 2004 5:36 pm

Since I did not get an answer in the "qnx.newuser" group, please allow
me to crosspost the following message here.

I did get an anwer to one of my questions in the "eclipse platform"
newsgroup in the meanwhile. I attach the answer to the end of this
posting also.

It would be nice if someone from QSSL could elaborate on the possible
future availability of 1.4.1 Java VMs for QNX.

Thanks!

Carl



"Carl Rosenberger" <carl@db4o.com> wrote in message
news:<btc7qu$9gv$1@inn.qnx.com>...

Hi all,

I have tried to install Eclipse 2.1.2 on Neutrino/Photon 6.2.1.

With J9 2.0 (Target: 20030313) everything appears to work fine,
except for the tabpages in the preferences.

Trying to track the tabpage problem down, I can reproduce it with
the SWT tabpage snippet code and the following two swt.jar builds:
- libswt-photon-2135.so
- libswt-photon-3019.so

I have posted the above issue as a bug to Eclipse Bugzilla...
https://bugs.eclipse.org/bugs/show_bug.cgi?id=49531
....so I hope the Eclipse team will come up with a solution soon.

Since I know that Eclipse is deployed with some QNX versions,
- which SWT version is being used?
- which J9 build is being used?

I also wonder why the latest Eclipse builds are not supplied for QNX,
how come?

Thanks in advance for any information.

Kind regards,
Carl
--
Carl Rosenberger
db4o - database for objects - http://www.db4o.com



"Grant Gayed" <grant_gayed@ca.ibm.com> wrote in message
news:<btkr7m$v7r$1@eclipse.org>...
Carl,

The Photon builds stopped because beyond Eclipse 3.0M3 a vm >= 1.4.1 is
required in order to run Eclipse, and there wasn't a reliable one
available for Photon at the time (and there may still not be, I'm really
not sure). Updated swt builds for photon are still made though since
swt's only requirement is a vm >= 1.8.

If you know of a good Photon 1.4.1 vm then please post a message to the
swt newsgroup, and the Eclipse Photon builds will likely be resumable.

Grant

Chris McKillop

Re: Repost: Which Eclipse version?

Post by Chris McKillop » Mon Jan 19, 2004 3:42 pm

I did get an anwer to one of my questions in the "eclipse platform"
newsgroup in the meanwhile. I attach the answer to the end of this
posting also.

It would be nice if someone from QSSL could elaborate on the possible
future availability of 1.4.1 Java VMs for QNX.
There isn't really anything to say yet. It is being worked on.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Carl Rosenberger

Re: Repost: Which Eclipse version?

Post by Carl Rosenberger » Tue Mar 02, 2004 9:51 pm

Carl Rosenberger wrote:
With J9 2.0 (Target: 20030313) everything appears to work fine,
except for the tabpages in the preferences.

Trying to track the tabpage problem down, I can reproduce it with
the SWT tabpage snippet code and the following two swt.jar builds:
- libswt-photon-2135.so
- libswt-photon-3019.so
Hi again,

apparently the Eclipse developer in charge, Silenio Quarti, can not
reproduce the problem on his system. See his message here:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=49531

Is it possible that this problem only occurs with the Photon patch
that I installed?
"patchA-nc.qpr"

It looks like the QNX website was completely modified and I can't
find the patch anymore, to point Silenio to it.

Any hints?

Thanks.


Kind regards,
Carl
--
Carl Rosenberger
db4o - database for objects - http://www.db4o.com

Chris McKillop

Re: Repost: Which Eclipse version?

Post by Chris McKillop » Tue Mar 02, 2004 11:50 pm

Carl Rosenberger <carl@db4o.com> wrote:
Carl Rosenberger wrote:
With J9 2.0 (Target: 20030313) everything appears to work fine,
except for the tabpages in the preferences.

There are issues with the tab pages on 6.2.1 - and there is a fix in
the SWT for them. What version of QNX are you using?

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Carl Rosenberger

Re: Repost: Which Eclipse version?

Post by Carl Rosenberger » Mon Mar 08, 2004 2:58 pm

Chris McKillop wrote:
What version of QNX are you using?
6.2.1 NC with patchA-nc.qpr, with the localisation set to a German
keyboard and the language set to US-English.

There are issues with the tab pages on 6.2.1 - and there is a fix in
the SWT for them.
I would be grateful for a pointer to a download site.

I have tried just about any download available from www.eclipse.org ,
including the latest nightly build with libswt-photon-3041.so.
None of them worked for me.


Kind regards,
Carl
--
Carl Rosenberger
db4o - database for objects - http://www.db4o.com

Chris McKillop

Re: Repost: Which Eclipse version?

Post by Chris McKillop » Mon Mar 08, 2004 4:26 pm

Carl Rosenberger <carl@db4o.com> wrote:
Chris McKillop wrote:
What version of QNX are you using?

6.2.1 NC with patchA-nc.qpr, with the localisation set to a German
keyboard and the language set to US-English.
I belive that patchA-nc.qpr isn't for 6.2.1. So I wouldn't use that,
your are probably backing out more current stuff for older stuff.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Carl Rosenberger

Re: Repost: Which Eclipse version?

Post by Carl Rosenberger » Mon Mar 08, 2004 10:02 pm

Chris McKillop wrote:
What version of QNX are you using?

6.2.1 NC with patchA-nc.qpr, with the localisation set to a German
keyboard and the language set to US-English.

I belive that patchA-nc.qpr isn't for 6.2.1. So I wouldn't use that,
your are probably backing out more current stuff for older stuff.
Thanks for the hint, but patchA-nc.qpr solved the problem that the
6.2.1 NC localisation had with my German keyboard.

I installed the patch since it was recommended on your website (if I
remember correctly).

What do you suggest?

Kind regards,
Carl
--
Carl Rosenberger
db4o - database for objects - http://www.db4o.com

Chris McKillop

Re: Repost: Which Eclipse version?

Post by Chris McKillop » Tue Mar 09, 2004 5:46 am

Thanks for the hint, but patchA-nc.qpr solved the problem that the
6.2.1 NC localisation had with my German keyboard.

I installed the patch since it was recommended on your website (if I
remember correctly).

What do you suggest?
You are pretty much out of luck. If you use PatchA (which I belive
is 6.2.0) then a Photon work-around in SWT for 6.2.1 will break the
tab folders. Your only option would be to build a custom SWT without
that check for 6.2.1 in the TabFolder.java code.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Post Reply

Return to “qnx.development_tools”