GCC on qnx4 : bad return code

bridged with qnx.qnx4
Post Reply
dominix

GCC on qnx4 : bad return code

Post by dominix » Fri Jul 06, 2007 8:28 pm

hello all.

On my way to send my data to a Database, I'm tring to compile
different products and I have a strange problem with gcc.

I have watcom 10.6 that run fine
I have installed gcc from JC michelot site
gcc281-qnx4-r19 : gcc is required to compile some product.
(I just untared it) it seems to work cause it compile fine.

my problem is : when I compile some test program the return
code is not the rigth one.

for ex:
# cat hello.c
main() {
return 0;
}
# gcc hello.c -o hello
# ./hello ; echo $?
148
#

the same process with wcc produce a return code of 0

any idea of what went wrong ?
thanks for your advices.

--
dominix

maschoen

RE: GCC on qnx4 : bad return code

Post by maschoen » Sun Jul 08, 2007 7:49 am

Try instead of "return 0", "exit(0)". If this
works, then there is a library problem.
main() is not usually the actual entry point for a 'C' program, just a
routine called
by the initialization code. The return from main() should be sent to
exit(), and
maybe it is not.

dominix

Re: GCC on qnx4 : bad return code

Post by dominix » Mon Jul 09, 2007 7:00 pm

"maschoen" <maschoen@pobox-dot-com.no-spam.invalid> a écrit dans le message
de news: f6q4te$2jk$1@inn.qnx.com...
Try instead of "return 0", "exit(0)". If this
works, then there is a library problem.
main() is not usually the actual entry point for a 'C' program, just a
routine called
by the initialization code. The return from main() should be sent to
exit(), and
maybe it is not.
I was missing watcom c++.
it is required to make gcc works.
thanks for pointing this.

Dx

Post Reply

Return to “qnx.qnx4”