Problem with HAM on PowerPC architecture. QNX 6.3 SP1

bridged with qnx.public.sysadmin
Post Reply
Veer

Problem with HAM on PowerPC architecture. QNX 6.3 SP1

Post by Veer » Mon Jan 16, 2006 7:53 am

hi,
I am using ham for automatically executing my modules or
restarting them in case they terminate abnormally or are terminated
by a user, and it's working fine on the x86 as well as ppc
architecture :D. The problem is when i want to legally shutdown my
application. What i am doing is first calling ham_detach_name to
deattach the module and then sending it a message to quit, on which
the module terminates itself ... this seems to be working fine on
x86 and the module terminates .. but when i try to use the same code
on ppc the ham_detach_name is successful ( it returns 0 for the first
time and returns error if i try to detach it after that ) .. but when
the module terminates itself .. the ham restarts the module which
isn't desired :( .. Please help me out on this.

Anees Koodathai

Re: Problem with HAM on PowerPC architecture. QNX 6.3 SP1

Post by Anees Koodathai » Fri Mar 24, 2006 2:41 pm

New Folder (2)

John Nagle

Reducing MTU on Ethernet interface - how?

Post by John Nagle » Mon May 29, 2006 6:21 pm

I need to reduce the MTU on a QNX Ethernet interface to
allow operation with an upstream router to a DSL line.
(MTU discovery isn't working due to a router firmware problem.)
Is there some way to do this?

(I know about "sysctl -w net.inet.tcp.mss_ifmtu=1", but that
doesn't help; that's for when QNX is running the PPPoE client itself.)

QNX 6.21, x86

John Nagle

(I still keep one QNX desktop machine around from the Overbot project,
to support the students at UC Santa Cruz who now have the Overbot.
and like the Overbot, it runs 6.21.)

Peter Weber

Re: Reducing MTU on Ethernet interface - how?

Post by Peter Weber » Wed Jul 19, 2006 1:06 pm

Hi John,
may you should set the MTU size if you configure/start your interface.
Using sysctl is too late.
cheers,Peter

"John Nagle" <nagle@overbot.com> schrieb im Newsbeitrag
news:e5fdpu$1sn$1@inn.qnx.com...
I need to reduce the MTU on a QNX Ethernet interface to
allow operation with an upstream router to a DSL line.
(MTU discovery isn't working due to a router firmware problem.)
Is there some way to do this?

(I know about "sysctl -w net.inet.tcp.mss_ifmtu=1", but that
doesn't help; that's for when QNX is running the PPPoE client itself.)

QNX 6.21, x86

John Nagle

(I still keep one QNX desktop machine around from the Overbot project,
to support the students at UC Santa Cruz who now have the Overbot.
and like the Overbot, it runs 6.21.)

Post Reply

Return to “qnx.public.sysadmin”